您现在的位置是:首页 > PHP框架交流PHP框架交流

composer 制作安装包出现的几个问题的总结

上善若水2021-12-31 14:39:19【PHP框架交流】 1907人已围观

简介composer 制作安装包出现的几个问题的总结.或许你也会遇到问题. composer安装包制作完成后出现了Could not find a version of package fierykyl

composer 制作安装包出现的几个问题的总结.或许你也会遇到问题.

  1. composer安装包制作完成后出现了Could not find a version of package fierykylin/aliexpress matching your minimum-stability (stable). Require it with an explicit version constraint allowing its desired stability. 上次成功将扩展包给安装上了,但是奈何扩展包安装不上,
    解决办法
    用安装dev版本代替 composer require fierykylin/aliexpress:dev-master

  2. unexpected Value Exception Error while installing fierykytin/aliexpress, composer plugin packages should have. a class defined in their extna key to be usable.

由于自己扩展包type选择错误出现的问题 扩展包 composer.json修改成

    "type": "library",
  1. git : 无法将“git”项识别为 cmdlet、函数、脚本文件或可运行程序的名称。请检查名称的拼写,如果包括路径,请确保路径正确,然后再试一次。
    所在位置 行:1 字符: 1

    git 命令不存在 用git 自带的黑框框运行

4.发现自己的扩展包多了一个层级,原因是自己多加了一层,修改后重新发布更新仓库.

  1. 必须加上:dev-master 才能拉取 仓库打一个标签 发布一个v1.0的稳定版,然后去composer更新仓库即可.

完成.

Tags: composer

很赞哦! (2)

随机图文

文章评论

站点信息

  • 建站时间:2019-10-24
  • 网站程序:Thinkphp6 Layui
  • 文章统计223篇文章
  • 标签管理标签云
  • 统计数据cnzz统计
  • 微信公众号:扫描二维码,关注我们